Intermittent service account authentication failures

Incident Report for Disruptive Technologies

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 11:45 CEST

Monitoring

Starting 5 Aug 2026 at approximately 20:50 UTC , a portion of service account token requests to the authentication API (/oauth2/token) returned HTTP 400 errors. This affected machine-to-machine integrations whose HTTP client sent a non-utf-8 charset in the request's Content-Type header. Interactive (browser) sign-in was not affected.

Cause: A recent platform upgrade included a newer framework version that applied stricter request-encoding validation, rejecting some previously valid token requests.

Resolution: We're deploying a fix that restores the previous request handling. Affected integrations should start operating normally shortly.
Posted Aug 06, 2026 - 10:51 CEST
This incident affected: API.