Cellular outage in the UK

Incident Report for Disruptive Technologies

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 08:25 CET

Monitoring

Affected devices are now successfully reconnecting to our cloud. We will continue to monitor the situation until the issue is fully resolved.
Posted Oct 27, 2025 - 01:13 CET

Investigating

We are currently investigating a cellular incident affecting Cloud Connectors (1st and 2nd Gen) in the UK, resulting in disconnections from our cloud.
Posted Oct 27, 2025 - 00:15 CET
This incident affected: Cloud Connector.