Number of Cloud Connectors Disconnected
Incident Report for Disruptive Technologies
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 18:57 CET
Update
One of our cellular providers have detected an issue and are currently investigating the cause.
Posted Mar 22, 2024 - 17:55 CET
Investigating
We are currently investigating this issue.
Posted Mar 22, 2024 - 17:02 CET
This incident affected: Cloud Connector.